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Tutorial 4 

Assembly Structure and Drawing 

Purpose: 

To give the student the basic knowledge related to the creation of a constrained assembly 

structure and on how to make an assembly drawing.  

Reference: 

Use the 04-Bearing_Support_Assy.pdf file, the related part files and the R20-

D_Size.CATDrawing file. 

1 – Launch CATIA® 

 If a product file is automatically created, keep it and skip Step 2. 

2 – Create a new product 

 Use File>New to launch the New dialog box. 

 Using the scroll bar, select Product in the list. 

 

 In the Part Number dialog box, replace Product1 by Bearing_Support_Assembly. 
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 Click the OK button to close the dialog box. 

3 – If necessary, organize the environment 

 If more information is necessary about this, review Tutorial 1. 

4 – Load the first part alone, to set up the product coordinate system 

 Click the Existing Component tool icon  to load a part that has already be modeled 

and that is stored in a dedicated folder. After clicking, nothing happens until the 

user clicks the name of the product, at the top of the Product Specification Tree. Then, 

a dialog box opens to allow the user to browse and select the part(s) that has (ve) 

to be inserted in the product. 

 

 At this moment, one part only must be selected in order to give the user the 

opportunity to control the way the assembly will be displayed using the different 

view presets. 

 Browse to locate the folder named Bearing_Support_Assy and select the 

Base.CATPart file and click on the Open button (Sorry for the illustration! A French 

version of Windows is used…) 

 Pull the Quick View toolbar  in the working area and make some 

visualization trials. The product reacts the same way the part reacts when it is open 

alone in a different window. (Try it if you are not sure). 

 It is important to have a first part that realigns properly when the Quick View tools 

are used. If it is not the case, you will struggle when you will work in the assembly 
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and you will struggle again when will come the time to extract assembly and detail 

views in the drawing.  It is worth the time to make some tests at first to save time 

later on. 

 

 Pull the Constraint toolbar  in the working area. 

 Click the Fix Component tool icon  and select the base to make it the reference 

for the assembly.  

5 – Load the other reference parts of the assembly 

 Click the Existing Component tool icon  once again to select the rest of the parts. 

 Click in the selection area to make it active and then, key in CTRL+A to select all 

files present in the folder. 

 Press the CTRL key alone and unselect the Base.CATPart file that is already 

present in the product and the .pdf file that cannot be open in CATIA® and that will 

return an error message if you try to open it. Click on the Open button. 
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 All parts will appear in the product but will be superimposed since they all have 

been modeled close to the origin of their respective .CATPart file. 

 

 Click the Explode tool icon  to move all the parts from their original location. 

Accept all default values by clicking on the OK button. 

 

 A warning message will appear. Confirm by clicking on the Yes button (Oui in the 

illustration…). 

 

 All reference parts are now easy to see in the product structure.  Note that the 

assembly needs an update. This is due to the displacement of the base that was 

already fixed. Click the Update all  tool icon to relocate the base to its original 

location. 
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6 – Relocate the reference parts 

Since some parts may be difficult to see because they are hidden by other parts or are 

inside other parts, it is a good practice to move the hidden parts in order to identify them. 

Some tools are available to the user to accomplish this task. 

 First, click the Manipulation tool icon . 

 In the dialog box that appears, click to select a linear translation, a rotation or a 

planar translation and then select and drag any part to a new location. 

 

 Orient the bolt in order to relatively align it with the axis of the hole in the base part. 

 

 Now, click the Snap tool icon . 

 Click the red shaft cylindrical face. A reference axis will appear. Then, click the 

base part cavity’s cylindrical face that will receive the shaft. A location axis will 

appear allowing the user to flip the part. Click anywhere in the blue working area to 

complete the operation. The shaft will be properly aligned in its cavity, but no 

constraint will be created. 
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 Next, bring the mouse cursor over the red square found on the Compass. The cursor 

will change for a four-pointing arrow icon. 

 

 Click the red square and drag the Compass over one of the base part’s inclined 

faces. Drop it. 

 

 The edges of the Compass turn green and the Base item is highlighted in the Product 

Specification Tree. The part is now selected and ready to be moved. Click to select 

any green edge of the Compass and move the cursor to create a linear or rotative 

displacement. Since the base part is moved, the Update all tool icon   will turn on. 

Click the icon to update the product and return the base to its original location and 

click anywhere in the blue working area to deactivate the part. 
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 Click the Washer item in the Product Specification Tree. The Compass will turn on once 

again. Click any edge to drag the washer to a new position. The washer will move 

but the relative position between the washer and the Compass may make the 

operation more complex to visualize. 

 

 The Compass could be dragged and dropped to any new part that needs to be 

moved in the product, but to make the user’s life easier, it is possible to preset this 

behavior by accessing the Compass’ context menu and selecting the Snap 

Automatically to Selected Object. To access the context menu, just bring the mouse 

cursor over the Compass’ red square and right-click. 

 

 From now on, every time a part will be selected either directly (in the working area) 

or by its representation in the Product Specification Tree, the Compass will relocate on 

the selected part making future transformation much easier. 

 Roughly align all the reference parts. Make sure the cover hole having a blue inner 

cylindrical face is aligned to the corresponding base hole. Assembly constraints will 

align the parts but a 180° flip is always possible.  Making the rough alignment will 

take a few minutes but will prevent a number of frustrations… 
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 Access the Compass’ context menu to unselect the Snap Automatically to Selected 

Object option and drag the Compass onto the XYZ tripod located in the bottom right 

corner of the screen. This will relocate the Compass to its original location. 

 

 Save the product. 

 

7 – Loading the missing parts 

Some parts are still missing in the assembly. They could be loaded by using the Existing 

Component tool , shown previously. This will load new instances of the selected parts in 

the product and would insert them at the exact same location where its reference part was 

when it was first loaded. Other options can be used to create new instances of a part 

already loaded. 

 Bring the mouse cursor over the bearing item in the Product Specification Tree. Right-

click to access the context menu and select the Copy option. 

 Move the cursor over the product name, at the top of the Product Specification Tree. 

Right-click to access the context menu and select the Paste option. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 9 

   

 Note that a new bearing instance is created at the end of the tree (Bearing.2). This 

new instance is superimposed to the first one (Bearing.1). 

 

 Use one of the means shown previously to relocate the second bearing on the 

other side of the support. 

 

 Click the Fast Multi Instantiation tool icon  and select the spacer to create a 

second instance. The new spacer is automatically offset from its reference. Using 

this tool is definitely the optimal way to insert missing parts in an assembly since it 

is possible for the user to double-click the icon at first to keep the tool active and 

then make new instances of any missing part. 
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 Use one of the means shown previously to relocate the second bearing on the 

other side of the support. 

 

 It is not necessary to create new instances for the washer and the bolt. A different 

approach will be used to insert the missing parts. 

 

8 – Creating assembly constraints 

 Pull the Constraints toolbar   in the working area. Now that 

more than one part is present in the product, all constraining tools are available to 

the user. 

 Double-click the Coincidence Constraint icon  to keep the tool active. 

 The Assistant dialog box will pop-up to warn the user about the fact that constraints 

are created in the active product or sub-product only. Read and understand the 

message and click the Do not prompt in the future checkbox and close the dialog box. 
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 Create two coincidence constraints between the two top spacer holes and the two 

corresponding base holes. Select the cylindrical face of a hole to access its axis. If 

the axis does not show up, zoom in to make the selection. It is a graphical 

limitation. 

 

 Click on the Coincidence Constraint icon  once again to deactivate the tool. 

 Click the Contact Constraint tool icon  and select the bottom face or the spacer 

and the base face that will receive it. 

 

 Click the Update All tool icon  to force the product’s regeneration and bring the 

spacer to its final location. 
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 Repeat the previous operations to constrain the bottom spacer. 

 

 Use coincidence constraints to bring the shaft and the two bearing aligned on the 

base cavity’s axis. Update the product. 

 

 Use contact constraints to locate the two bearings in their seats. Update the 

product. 
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 Click on the Offset Constraint tool icon , rotate about the product and select the 

base’s side face and the protruding shaft’s end face. A dialog box will pop-up. 

 

 In the Offset edition box, a value is highlighted in blue. It may be positive or negative 

depending on the order taken to select the two offset faces. To decrease the 

protruding value make sure to keep the same sign on the value inserted. In this 

scenario +1.5 inches should be used to center the shaft in the base. 

The problem with this approach is that the shaft will no longer be centered if its length is 

modified. In the original shaft part, the revolution was made symmetrical according to the 

origin, making its yz plane centered on the part. 
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 Click on the plus sign found on the Constraints item’s left side in the Product 

Specification Tree. This will expand the Constraints group. 

 

 Select the offset constraint, at the end of the list, and delete it. 

 Create a coincidence constraint between the shaft’s plane and the base’s plane 

found at the other end of the base. No update should be necessary since the shaft 

was already centered. 

 

 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 15 

 Create coincidence constraints between two cover holes and their two 

corresponding holes on the base. 

 

 Create a contact constraint between one of the spacers and the cover’s 

corresponding face. 

 

  Update the product. 

 

 Use a coincidence and a contact constraint to constrain the washer on the cover 

blue hole’s spotface. Do not forget to zoom in to ease the selection if necessary. 

 

 Repeat the operations for the bolt. 
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 Click the Angle Constraint tool icon  and select the cover’s side face and the bolt 

head side’s face that is the most parallel to it. 

 

  In the dialog box, check the Parallelism check box and click the OK button. 

 

  Update the product. The bolt head is aligned. 

 

9 – Generate pattern elements 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 17 

 Click the Reuse Pattern tool icon . 

 Zoom in and select the washer first. Then, select the inner face of any cover’s hole 

and click the Apply button; the dialog box will stay open. 

 

 Have a look at the dialog box content.  Note also that the three proposed instances 

and the Assembly features group that are added at the end of the Product Specification 

Tree.  This approach may be correct for small patterns but with a large number of 

parts being used in a pattern (parts kept together by a bolt, 2 washers, a nut and a 

locknut for example…) the tree will rapidly become quite long… 

 Click on the OK button to close the dialog box and click the Undo tool icon  to 

delete the repetition. 

 Use the Reuse Pattern tool once again and make the same selections (washer and 

hole inner face) but this time, click the Put new instances in a flexible component 

checkbox, found in the dialog box’s lower left corner, before clicking the Apply 

button. 
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 Note that in this second approach, the three new instances are grouped under a 

flexible assembly component. The name of this component is usually quite long, 

taking a lot of space in the working area. It is usually a good practice to edit the 

name of the component and make it shorter. Using this way, adding three or thirty 

instances in a pattern will take the same amount of space when the component is 

collapsed. 

 Click the OK button to close the dialog box and repeat the procedure for the bolt. 

 Save the product. 
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10 – Hiding planes 

 To complete, it would be nicer to hide all planes in the assembly.  Most 

methodologies ask to hide all the planes before making a final save on a part, but 

practice is usually different…  Here the correct and permanent way to hide the 

planes is to access the base and the shaft part and to hide the plane shown in 

each of them. A quick way to hide all planes temporarily is to hide them through the 

product. This can be done by using the following Power Input: t:plane, all. 

 

By doing this, all planes in all product’s parts will be selected. Click the Hide/Show 

tool icon  a first time.  All planes that were hidden will appear in the product. 

 

 Repeat the procedure. All planes will then disappear. To save some typing time, 

you can click in the Power Input area and use the keyboard up arrow to recall the 

last entry. Remember this trick, you’ll probably use it in the first assembly you will 

build from scratch… and in some others! 

11 – Creating a scene 

An exploded view will be created on the drawing. In order to make it, it is not possible to 

explode the assembly in the working environment. A scene will be necessary. 

 Click the Enhanced Scene tool icon  to create a new scene. 
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 A dialog box will pop-up. Give a name to the scene, uncheck the Automatic naming 

checkbox and set the Overload Mode to Full. 

 

 The product environment will change and a green background will replace the 

working area blue background. A warning message will also inform the user that 

displacements cannot be reset automatically since assembly constraints no longer 

exist in a scene. Click the Do not display this message again checkbox. 

 

 Rotate about the assembly in order to take a view point that will show the back left 

side of the product. Click the Save Viewpoint tool icon   to get this viewpoint each 

time the scene will be accessed. 
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 Move and drop the Compass to the cover’s top face and use the CTRL key to select 

all assembly items except the base. Move all the parts a certain distance thus 

avoiding superimposition of parts in the view and then pressing the CTRL key to 

deselect the shaft and the two bearings. Move the remaining parts again and then 

stop and deselect the two spacers. Go on until all parts are properly shown. 

 

 Exit the scene and save the product. 

12 – Creating the assembly drawing 

 Use File>New From and browse to locate the format file named R20-

D_Size.CATDrawing. This will create a new drawing file containing a border and a 

title block. 
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 The same way orthogonal views were extracted in Tutorial 1, click the Front View 

tool icon  to extract the first assembly view. 

 Bring the mouse cursor over the red dashed view frame and right-click to access 

the view’s context menu. Select the Properties option. 

 

  Set the Scale to 1:2. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 23 

 

 Click the OK button, delete the view name from the view and relocate the view in 

the sheet’s bottom left corner. 

 

 Click the Projection View tool icon  to extract a top and a side view. Delete the 

view names that are automatically created. Note that the two new views are 

already at a 1:2 scale. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 24 

 

 Click the Isometric View tool icon . Switch windows to access the product. Click 

on the 3-D Isometric View tool icon  to properly align the assembly and click on 

any of the parts’ faces. A window switch will occur and an isometric view will be 

created in the drawing. Edit the view name, making the top line 0.25 inch high and 

stating: ISOMETRIC, in capital letters. Make the second line 0.15 inch high and 

stating: SCALE 1:2. Make the two texts centered. 

 

 Edit the view properties’ dialog box.  

 Change the view scale to 1:2 and click on the Apply button. 

 Scroll down to be able to change the View generation mode to Raster and click on the 

Options button to set the Raster Mode to Shading with edges. Click on the Close and the 

OK buttons. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 25 

   

 Locate the isometric view in the drawing’s top right corner. 

 Switch windows to get back to the assembly. 

 Double-click on the Exploded_View scene item in Product Specification Tree. This will 

allow the user to access the scene. 
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 Switch windows to access the drawing. 

 Click the Isometric View tool icon to extract the last view.  

 Switch windows to access the scene. 

 Click the scene name in the Product Specification Tree. 

 Click any solid’s face. 

 Complete the view extraction. 

 

 

 Edit the view name to make it EXPLODED VIEW and SCALE 1:2, using the same 

standards as before. 

 Access the view properties’ dialog box to change the scale to 1:2. 

 Relocate the view in the drawing. 
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 Use Edit>Sheet Background to complete the drawing information. Delete the Material 

line in the notes and fill out the title block. When done use Edit>Working Views to get 

back to the standard environment. 

 

 Save the drawing. 

 Double-click on the Dimensions tool icon  to create the three overall dimensions. 

Make them 0.150 inch high, use only one decimal place and add parenthesis as 

prefix and suffix to show they are reference dimensions. 
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 Expand the Break View toolbar hidden under the Broken View tool icon . 

 Make sure the front view is active. 

 Click the Breakout View tool icon  and define a breakout region, in the front view, 

in a way that the bottom bolt will become fully visible. Note that it is possible to 

rotate about the content in the 3D Viewer the same way it is done in the working 

area. 

  Bring the mouse cursor near the representation of the bottom left washer in the 

right view and click the ellipse. Selecting a circle or an ellipse in a view projected 

from the one in which the breakout will be generated is probably the fastest way to 

align the cutting plane with the axis of a hole. 

 Click the OK button in the 3D Viewer dialog box to complete the breakout definition. 
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 Since the breakout cut the bolt and the washer and that drafting standards ask to 

do not cut standard parts, access the view context menu and activate the Overload 

Properties option. 
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 Select one line on the bolt and one line on the washer. Both instances should 

appear in the Characteristics dialog box. 

 Using the CTRL key select both instances in the dialog box and click on the Edit 

button. The Editor dialog box will pop-up. 

 

 Uncheck the Cut in section views checkbox and click the OK buttons in each of the 

dialog boxes. The bolt and the washer should no longer be sectioned. 

 

 Create a vertical line to the right of the assembly representation in the front view. 

 Expand the Text toolbar  hidden under the Text tool icon . 

 Double-Click the Balloon tool icon and identify each of the assembly components by 

using a counterclockwise incremental approach. Start at the bottom of the line and 

center each balloon to the line going up. When aligning balloons vertically or 
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horizontally, the drawing grid may be used instead as a reference, but it happens 

that balloons are aligned along one of the assembly’s side neither vertical nor 

horizontal and then, the construction line technique is more practical. 

 Hide the line in no-show. It may be useful in the future. 

 Make sure all your balloon text is 0.150 inch high. 

 

 Zoom in to have a look at your arrow heads: they should be filled. 

 If they are not, click on the first leader line and locate the yellow diamond shape that 

appears at the tip of the arrow. Bring the mouse cursor over the diamond shape 

and right click to access the context menu. Select the Symbol Shape option and 

choose Filled Arrow. Repeat the procedure for all balloons. 

 

 Click the New View tool icon  and click about one inch over the title block to 

locate the view. 
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 Use Insert>Drawing>Sheets>New Detail Sheet to add a detail sheet to the drawing. A 

view is already present and active in this new sheet. 

 

 Click the Table tool icon  and edit the content of the Table Editor to have 8 

columns and 8 lines. 

 

 Click in the view to locate the table. Make sure the table’s lower right corner is 

perfectly aligned to the view origin. This will facilitate its insertion later on. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 33 

 

  Double-click the table. A new frame will appear. 

  Bring the mouse cursor under the first column and right click to access the context 

menu. 

 

 Select the Size option and then the Set Size sub-option. 

 Set the first column width to 0.5 inch and click the OK button to apply the change. 

 

 Set the other column widths to 0.5, 0.5, 2.5, 2.5, 1.125, 1 and 0.5 inches. 

 Bring the mouse cursor to the left of the bottom line. 



Tutorial 4 – Assembly Structure and Drawing 

© Michel Michaud - 2012 34 

 Using a similar approach, set the bottom line height to 0.375 inch. 

 Make all the remaining lines 0.3 inch high.  

 Click outside of the table to complete the edition. 

 Relocate the table in the view if necessary. 

 

 Double-click the table to activate it. 

 Double-click in the bottom left cell. Add NO in the Text Editor. Click the OK button to 

complete the text creation. 

 

  Add the following texts in the remaining columns: QTY, SHEET, PART, 

MATERIAL, STOCK NO, CAGE NUMBER, ALTER. 

 

 Keep the table activated. 
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 Click and drag all the bottom line cells. They will become black.  

 

 Bring the mouse cursor over the black background and right-click to access the 

context menu. Select the Properties option. 

 In the Font tab, set the Size to 0.080 inch. In the Text tab, set the Position Anchor Point 

to Middle Center. Click the OK button to complete the edition. 

 

 A basic Parts List is now available as a detail. 

 Save the drawing. 

 Get back to the first sheet by selecting its tab in the screen’s top left corner. 

 Click the Instantiate 2D Component tool icon to insert the Parts List in the view 

previously created over the title block. 

 Access the detail sheet by selecting its tab and select the table. It will appear in the 

first sheet’s view. Locate the table’s bottom right corner at the view’s origin. 
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 Delete the view name and relocate the view in order to align the table’s left side to 

the drawing border. Do not hesitate to zoom in to get a perfect fit. 

 

 The inserted table is still linked to its definition stored in the detail sheet. Should a 

new copy be necessary in a different sheet, for a sub-assembly for example, it 

would be impossible to edit one table without editing the other. In this case, it is 

preferable to break the link between the instance and the reference detail. 

  Bring the mouse cursor anywhere over the table and right-click to access the 

context menu. Select the Explode 2D Component option found under 2D Component.1 

(Instance) object. The table is now stand alone. 
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  Edit the table to complete the Parts List. 

 

  The drawing is about to be completed. 
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If desired, it is possible to add color to the drawing. This may be nice for a portfolio but is 

usually not an industry standard… 

 Double-click the shaded isometric view border to make it active and right-click it to 

access the context menu. Select the Properties option. 

 In the View tab, check the 3D Colors checkbox and click the Apply button. Click the 

OK button to complete the operation. 
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 Click on the Display View Frame as Specified for Each View tool icon   to make all 

view frames disappear from the drawing. 

 

 Save the drawing. 

 

Thanks to Alice Michaud for revising this text. 


